Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002

Project: Drupal core
Date: 2018-March-28
Security risk: *Highly critical* 21∕25
Vulnerability: Remote Code Execution

Description

CVE: CVE-2018-7600

A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being completely compromised.

The security team has written an FAQ about this issue.

Solution

Upgrade to the most recent version of Drupal 7 or 8 core.

  • If you are running 7.x, upgrade to Drupal 7.58.* (If you are unable to update immediately, you can attempt to apply this patch to fix the vulnerability until such time as you are able to completely update.)
  • If you are running 8.5.x, upgrade to Drupal 8.5.1.* (If you are unable to update immediately, you can attempt to apply this patch to fix the vulnerability until such time as you are able to completely update.)

Drupal 8.3.x and 8.4.x are no longer supported and we don't normally provide security releases for unsupported minor releases. However, given the potential severity of this issue, we /are/ providing 8.3.x and 8.4.x releases that includes the fix for sites which have not yet had a chance to update to 8.5.0.

Your site's update report page will recommend the 8.5.x release even if you are on 8.3.x or 8.4.x. Please take the time to update to a supported version after installing this security update.

This issue also affects Drupal 8.2.x and earlier, which are no longer supported. If you are running any of these versions of Drupal 8, update to a more recent release and then follow the instructions above.

This issue also affects Drupal 6. Drupal 6 is End of Life. For more information on Drupal 6 support please contact a D6LTS vendor.

Note for Drupion customers

Non-composer based Drupal 7 and Drupal 8 websites, which opted for core updates per https://www.drupion.com/blog/automatic-drupal-core-updates-website-basis... should be updated automatically. If you didn't opt for automatic core updates then please either perform this security update manually by yourself or file a support request on https://dashboard.drupion.com.

Unfortunately, our automatic update backend is not compatible with Composer-installed websites yet, so manual update is required for them. Please file a support request and we will gladly get your websites updated.

Add new comment