JSON API - Moderately critical - Multiple Vulnerabilities - SA-CONTRIB-2018-15

Project: JSON API
Date: 2018-February-21
Security risk: *Moderately critical* 13∕25
Vulnerability: Multiple Vulnerabilities

Description

This module provides a JSON API standards-compliant API for accessing and
manipulating Drupal content and configuration entities.

* The module doesn't sufficiently associate cacheability metadata in
certain
situations thereby causing an access bypass vulnerability.
This vulnerability is mitigated by the fact that an attacker cannot
trigger an exploitable situation themselves.

* The module doesn't sufficiently check access in certain situations.
This vulnerability is mitigated by the fact that an attacker must have
permission to create entities of certain content entity types.

Solution: 
Install the latest version:

* If you use the JSON API module for Drupal 8.x, upgrade to JSON API 8.x-1.9

Add new comment